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Virtual Instrumentation With LabVIEW
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Course Goals

• Understand the components of a Virtual Instrument

• Introduce LabVIEW and common LabVIEW functions 

• Build a simple data acquisition application

• Create a subroutine in LabVIEW

•Work with Arrays, Clusters, and Structures

• Learn About Printing & Documentation Features

• Develop in Basic Programming Architectures

• Publish VIs on the Web 

This is a list of the objectives of the course.

This course prepares you to do the following:

• Use LabVIEW to create applications.

• Understand front panels, block diagrams, and icons and connector panes.

• Use built-in LabVIEW functions.

• Create and save programs in LabVIEW so you can use them as subroutines.

• Create applications that use plug-in DAQ devices.

This course does not describe any of the following:

• Programming theory

• Every built-in LabVIEW function or object

• Analog-to-digital (A/D) theory
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Section I

• LabVIEW terms

•Components of a LabVIEW application

• LabVIEW programming tools

• Creating an application in LabVIEW
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Front Panel
• Controls = Inputs
• Indicators = Outputs

Block Diagram
• Accompanying “program”

for front panel
• Components “wired”

together

LabVIEW Programs Are Called Virtual Instruments (VIs)

LabVIEW programs are called virtual instruments (VIs).

Stress that controls equal inputs, indicators equal outputs.

Each VI contains three main parts:
• Front Panel – How the user interacts with the VI.
• Block Diagram – The code that controls the program.
• Icon/Connector – Means of connecting a VI to other VIs.

The Front Panel is used to interact with the user when the program is running. 
Users can control the program, change inputs, and see data updated in real 
time. Stress that controls are used for inputs- adjusting a slide control to set 
an alarm value, turning a switch on or off, or stopping a program. Indicators 
are used as outputs. Thermometers, lights, and other indicators indicate 
values from the program. These may include data, program states, and other 
information.

Every front panel control or indicator has a corresponding terminal on the block 
diagram. When a VI is run, values from controls flow through the block 
diagram, where they are used in the functions on the diagram, and the results 
are passed into other functions or indicators.
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VI Front Panel

Front Panel 
Toolbar

Graph

Legend

Boolean
Control

Waveform
Graph

Icon

Plot

Legend

Scale

Legend

The front panel is the user interface of the VI. You build the front panel with 
controls and indicators, which are the interactive input and output terminals of 
the VI, respectively. Controls are knobs, pushbuttons, dials, and other input 
devices. Indicators are graphs, LEDs, and other displays. Controls simulate 
instrument input devices and supply data to the block diagram of the VI. 
Indicators simulate instrument output devices and display data the block 
diagram acquires or generates.

In this picture, the Power switchis a boolean control. A boolean contains either 
a true or false value. The value is false until the switch is pressed. When the 
switch is pressed, the value becomes true. The temperature history indicator is 
a waveform graph. It displays multiple numbers. In this case, the graph will plot 
Deg F versus Time (sec).

The front panel also contains a toolbar, whose functions we will discuss later.
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VI Block Diagram

Wire 
Data

Graph
Terminal

SubVI

While Loop
Structure

Block 
Diagram 
Toolbar Divide

Function

Numeric 
Constant

Timing 
Function

Boolean Control 
Terminal

The block diagram contains this graphical source code. Front panel objects 
appear as terminals on the block diagram. Additionally, the block diagram 
contains functions and structures from built-in LabVIEW VI libraries. Wires 
connect each of the nodes on the block diagram, including control and indicator 
terminals, functions, and structures.

In this block diagram, the subVITemp calls the subroutine which retrieves a 
temperature from a Data Acquisition (DAQ) board.  This temperature is plotted 
along with the running average temperature on the waveform graph
Temperature History.  The Power switch is a boolean control on the Front 
Panel which will stop execution of the While Loop.  The While Loop also 
contains a Timing Function to control how frequently the loop iterates.
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Express VIs, VIs and Functions

• Express VIs: interactive VIs with configurable dialog page

• Standard VIs: modularized VIs customized by wiring

• Functions: fundamental operating elements of 

LabVIEW; no front panel or block diagram

Express VIExpress VI Standard VIStandard VI

FunctionFunction

LabVIEW 7.0 introduced a new type of subVI called Express VIs.  These are 
interactive VIs that have a configuration dialog box that allows the user to 
customize the functionality of the Express VI.  LabVIEW then generates a 
subVI based on these settings.

Standard VIs are VIs (consisting of a front panel and a block diagram) that are 
used within another VI.

Functions are the building blocks of all VIs.  Functions do not have a front panel 
or a block diagram.
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Controls and Functions Palettes

Controls Palette
(Front Panel Window)

Functions Palette
(Block Diagram Window)

Use the Controls palette to place controls and indicators on the front panel. The
Controls palette is available only on the front panel. Select Window»Show 
Controls Palette or right-click the front panel workspace to display the 
Controls palette. You also can display the Controls palette by right-clicking an 
open area on the front panel. Tack down the Controls palette by clicking the 
pushpin on the top left corner of the palette.

Use the Functions palette, to build the block diagram. The Functions palette is 
available only on the block diagram. Select Window»Show Functions Palette 
or right-click the block diagram workspace to display the Functions palette. 
You also can display the Functions palette by right-clicking an open area on the 
block diagram. Tack down the Functions palette by clicking the pushpin on the 
top left corner of the palette.
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Operating Tool

Positioning/Resizing Tool

Labeling Tool

Wiring Tool

Shortcut Menu Tool

• Floating Palette
• Used to operate and modify 

front panel and block diagram 
objects.

Scrolling Tool

Breakpoint Tool

Probe Tool

Color Copy Tool

Coloring Tool

Tools Palette

Automatic Selection Tool

If automatic tool selection is enabled and you move the cursor over objects on 
the front panel or block diagram, LabVIEW automatically selects the 
corresponding tool from the Tools palette. Toggle automatic tool selection by 
clicking the Automatic Tool Selection button in the Tools palette. 

Use the Operating tool to change the values of a control or select the text within 
a control. 

Use the Positioning tool to select, move, or resize objects. The Positioning tool 
changes shape when it moves over a corner of a resizable object.

Use the Labeling tool to edit text and create free labels. The Labeling tool 
changes to a cursor when you create free labels.

Use the Wiring tool to wire objects together on the block diagram.
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Run Button 

Continuous Run Button

Abort Execution

Pause/Continue Button

Text Settings

Align Objects

Distribute Objects

Reorder

Resize front panel 
objects

Execution Highlighting 
Button

Step Into Button

Step Over Button

Step Out Button

Additional Buttons on 
the Diagram Toolbar

Status Toolbar

•Click the Run button to run the VI. While the VI runs, the Run button appears 
with a black arrow if the VI is a top-level VI, meaning it has no callers and 
therefore is not a subVI.

•Click the Continuous Run button to run the VI until you abort or pause it. You 
also can click the button again to disable continuous running.

•While the VI runs, the Abort Execution button appears. Click this button to 
stop the VI immediately.

Note: Avoid using the Abort Execution button to stop a VI. 
Either let the VI complete its data flow or design a method to 
stop the VI programmatically. By doing so, the VI is at a known 
state. For example, place a button on the front panel that stops the 
VI when you click it.

•Click the Pause button to pause a running VI. When you click the Pause 
button, LabVIEW highlights on the block diagram the location where you 
paused execution. Click the Pausebutton again to continue running the VI.

•Select the Text Settings pull-down menu to change the font settings for the VI, 
including size, style, and color.

•Select The Align Objects pull-down menu to align objects along axes, 
including vertical, top edge, left, and so on.

•Select the Distribute Objects pull-down menu to space objects evenly, 
including gaps, compression, and so on.

•Select the Resize Objectspull-down menu to change the width and height of 
front panel objects.
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•Select the Reorder pull-down menu when you have objects that overlap each 
other and you want to define which one is in front or back of another. Select one 
of the objects with the Positioning tool and then select from Move Forward, 
Move Backward, Move To Front, and Move To Back.

<the following items only appear on the bock diagram toolbar>

•Click the Highlight Execution button to see the flow of data through the block 
diagram. Click the button again to disable execution highlighting.

•Click the Step Into button to single-step into a loop, subVI, and so on. Single-
stepping through a VI steps through the VI node to node. Each node blinks to 
denote when it is ready to execute. By stepping into the node, you are ready to 
single-step inside the node.

•Click the Step Over button to step over a loop, subVI, and so on. By stepping 
over the node, you execute the node without single-stepping through the node.

•Click the Step Out button to step out of a loop, subVI, and so on. By stepping 
out of a node, you complete single-stepping through the node and go to the next 
node.
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Open and Run a Virtual Instrument

Example finder

1. Select Start » Programs » National Instruments » LabVIEW 7.0 »
LabVIEW to launch LabVIEW. The LabVIEW dialog box appears.

2. Select Find Examples from the Help menu. The dialog box that appears lists 
and links to all available LabVIEW example VIs.

3. You can browse examples by categories, or you can use a keyword search. 
Click the Searchtab to open the keyword browser.

4. In the “Enter Keyword(s)” box enter “Signal”

5. A list of related topics will appear in the exampleswindow. Double-click on 
signals, this will list examples on the right side.

6. Click on any program to see a detailed description of the example. Double-
click Signal Generation and Processing.vito launch this example.

This will open the “Signal Generation and Processing.vi” Front Panel.

Examine the VI and run it. Change the frequencies and types of the input signals 
and notice how the display on the graph changes. Change the Signal Processing 
Window and Filter options. After you have examined the VI and the different 
options you can change, stop the VI by pressing the Stop button.

Note You also can open the VI by clicking the Open VI button and navigating 
to labview\examples\apps\demos.llb\Signal Generation and Processing.vi.
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Control
Terminals 

Block Diagram Window

Front Panel Window

Indicator 
Terminals

Creating a VI

When you create an object on the Front Panel, a terminal will be created on the 
Block Diagram. These terminals give you access to the Front Panel objects from 
the Block Diagram code.

Each terminal contains useful information about the Front Panel object it 
corresponds to. For example, the color and symbols provide the data type. 
Double-precision, floating point numbers are represented with orange terminals 
and the letters DBL. Boolean terminals are green with TF lettering.

In general, orange terminals should wire to orange terminals, green to green, and 
so on. This is not a hard-and-fast rule; LabVIEW will allow a user to connect a 
blue terminal (integer value) to an orange terminal (fractional value), for 
example. But in most cases, look for a match in colors.

Controls have an arrow on the right side and have a thick border. Indicators 
have an arrow on the left and a thin border. Logic rules apply to wiring in 
LabVIEW: Each wire must have one (but only one) source (or control), and 
each wire may have multiple destinations (or indicators).

The program in this slide takes data from A and B and passes the values to both 
an Add function and a subtract function. The results are displayed on the 
appropriate indicators.
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Creating a VI – Block Diagram

In addition to Front Panel terminals, the Block diagram contains functions. Each 
function may have multiple input and output terminals. Wiring to these 
terminals is an important part of LabVIEW programming.

Once you have some experience programming in LabVIEW, wiring will 
become easy. At first, you may need some assistance. Here are some tips to get 
you started:

•The wiring tool  is used to wire to the nodes of the functions. When you “aim”
with the wiring tool, aim with the end of the wire hanging from the spool. This 
is where the wire will be placed.

•As you move the wiring tool over functions, watch for the yellow tip strip. This 
will tell you the name of the terminal you are wiring to.

•As you move the wiring tool over a terminal, it will flash. This will help you 
identify where the wire will attach.

•For more help with the terminals, right-click on the function and select Visible 
Items>>Terminals. The function’s picture will be pulled back to reveal the 
connection terminals. Notice the colors- these match the data types used by the 
front panel terminals.

•For additional help, select Help>>Show Context Help, or press CTRL+H . 
This will bring up the context help window. As you move your mouse over the 
function, this window will show you the function, terminals, and a brief help 
description. Use this with the other tools to help you as you wire.
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Wiring Tips – Block Diagram

Wiring “Hot Spot”

Clean Up WiringUse Automatic 
Wire Routing

Click To Select Wires

In addition to Front Panel terminals, the Block diagram contains functions. Each function may 
have multiple input and output terminals. Wiring to these terminals is an important part of 
LabVIEW programming.

Once you have some experience programming in LabVIEW, wiring will become easy. At first, 
you may need some assistance. Here are some tips to get you started:

•The wiring tool  is used to wire to the nodes of the functions. When you “aim” with the wiring 
tool, aim with the end of the wire hanging from the spool. This is where the wire will be placed.

•As you move the wiring tool over functions, watch for the yellow tip strip. This will tell you the 
name of the terminal you are wiring to.

•As you move the wiring tool over a terminal, it will flash. This will help you identify where the 
wire will attach.

•For more help with the terminals, right-click on the function and select Visible 
Items>>Terminals. The function’s picture will be pulled back to reveal the connection 
terminals. Notice the colors- these match the data types used by the front panel terminals.

•For additional help, select Help>>Show Context Help, or press CTRL+H . This will bring up 
the context help window. As you move your mouse over the function, this window will show 
you the function, terminals, and a brief help description. Use this with the other tools to help you 
as you wire.

•If your wiring becomes doesn’t look very good, right-click on the particular wire in question 
and choose Clean Up Wire to automatically re-route that wire.
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Wiring is very flexible in LabVIEW. Experiment with keystroke and clicking 
combinations when wiring. Here are some of the most often used features:

•Single, double, and triple clicking a wire selects the wire for movement or 
deletion

•Clicking while wiring tacks down a bend in the wire

•Right-clicking or pressing Escape while wiring cancels the wiring operation

Don’t worry about wire colors- LabVIEW will automatically select the right 
wire for each situation.

Automatically Wiring Objects

LabVIEW automatically wires objects as you place them on the block diagram. 
You also can automatically wire objects already on the block diagram. 
LabVIEW connects the terminals that best match and leaves terminals that do 
not match unconnected. As you move a selected object close to other objects on 
the block diagram, LabVIEW draws temporary wires to show you valid 
connections. When you release the mouse button to place the object on the 
block diagram, LabVIEW automatically connects the wires. Toggle automatic 
wiring by pressing the spacebar while you move an object using the Positioning 
tool. You can adjust the automatic wiring settings by selecting Tools » Options 
and selecting Block Diagram from the top pull-down menu.
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• Block diagram executes 

dependent on the flow of data; 

block diagram does NOT 

execute left to right

• Node executes when data is 

available to ALL input terminals

• Nodes supply data to all output 

terminals when done

Dataflow Programming

LabVIEW follows a dataflow model for running VIs. A block diagram node 
executes when all its inputs are available. When a node completes execution, it 
supplies data to its output terminals and passes the output data to the next node 
in the dataflow path. Visual Basic, C++, JAVA, and most other text-based 
programming languages follow a control flow model of program execution. In 
control flow, the sequential order of program elements determines the execution 
order of a program.

Consider the block diagram above. It adds two numbers and then subtracts 50.0 
from the result of the addition. In this case, the block diagram executes from left 
to right, not because the objects are placed in that order, but because one of the 
inputs of the Subtract function is not valid until the Add function has finished 
executing and passed the data to the Subtract function. Remember that a node 
executes only when data are available at all of its input terminals, and it supplies 
data to its output terminals only when it finishes execution.

In the code to the right, consider which code segment would execute first—the 
Add, Random Number, or Divide function. You cannot know because inputs to 
the Add and Divide functions are available at the same time, and the Random 
Number function has no inputs. In a situation where one code segment must 
execute before another, and no data dependency exists between the functions, 
use a Sequence structure to force the order of execution.
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Help Options

Context Help
• Online help
• Lock help
• Simple/Complex Diagram help
• Ctrl + H

Online reference
• All menus online
• Pop up on functions in diagram to access online inf o directly

Use the Context Help window and the LabVIEW Help to help you build and 
edit VIs. Refer to the LabVIEW Help and manuals for more information.

Context Help Window

To display the Context Help window, select Help»Show Context Help or press 
the <Ctrl-H> keys. When you move the cursor over front panel and block 
diagram objects, the Context Help window displays the icon for subVIs, 
functions, constants, controls, and indicators, with wires attached to each 
terminal. When you move the cursor over dialog box options, the Context Help 
window displays descriptions of those options. In the window, required 
connections are bold, recommended connections are plain text, and optional 
connections are dimmed or do not appear. Above is an example Context Help 
window.

Click the Simple/Detailed Context Help button located on the lower left corner 
of the Context Help window to change between simple and detailed context 
help. The simple mode emphasizes the important connections. Optional 
terminals are shown by wire stubs, informing you that other connections exist.

Click the Lock Context Help button to lock the current contents of the Context 
Help window. When the contents are locked, moving the cursor over another 
object does not change the contents of the window. To unlock the window, click 
the button again. You also can access this option from the Help menu.
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Click the More Help button to display the corresponding topic in the 
LabVIEW Help, which describes the object in detail.

LabVIEW Help

You can access the LabVIEW Help either by clicking the More Help button in 
the Context Help window, selecting Help»VI, Function, & How-To Help , 
clicking the sentence Click here for more help in the Context Help window, 
or pressing <Ctrl-?>.

The LabVIEW Help contains detailed descriptions of most palettes, menus, 
tools, VIs, and functions. It also includes step-by-step instructions for using 
LabVIEW features and links to the LabVIEW Tutorial, PDF versions of all the 
LabVIEW manuals and Application Notes, and technical support resources on 
the National Instruments Web site.



20

Exercise 1 - Convert °C to °F

Estimate completion time: 20 minutes. The exercise is easy, but since it will be 
the first VI that we actually create, it is good to allow ample time to explore the 
LabVIEW environment.

Instructions: Build a VI that converts °C to °F. When run, the VI should take an 
input value (°C), multiply it by 1.8, add 32, and display the result (°F). The front 
panel should display both the input value and the result. Save the VI as Convert 
C to F.vi.
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Debugging Techniques

• Finding Errors

• Execution Highlighting

• Probe

Click on broken Run button
Window showing error appears

Click on Execution Highlighting button; data 
flow is animated using bubbles. Values are 
displayed on wires.

Right-click on wire to display probe and it 
shows data as it flows through wire segment

You can also select Probe tool from Tools 
palette and click on wire

When your VI is not executable, a broken arrow is displayed in the Run button 
in the palette.

Finding Errors : To list errors, click on the broken arrow. To locate the bad 
object, click on the error message.
Execution Highlighting: Animates the diagram and traces the flow of the data, 
allowing you to view intermediate values.

Click on the light bulb on the toolbar.
Probe: Used to view values in arrays and clusters.

Click on wires with the Probe tool or right-click on the wire to set 
probes.

Breakpoint: Set pauses at different locations on the diagram.
Click on wires or objects with the Breakpoint tool to set breakpoints.

Use Debug DemonstrateVI from BASICS.LLB to demonstrate the options and 
tools.
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Section II – SubVIs

• What is a subVI?

• Making an icon and 

connector for a subVI

• Using a VI as a subVI
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Block Diagram Nodes

Icon                               Expandable Node Expanded Node 

• Function Generator VI

• Same VI, viewed three different ways

• Yellow field designates a standard VI

• Blue field designates an Express VI

Just as control or indicator terminals on the block diagram can be viewed as an icon or a 
simple terminal, subVIs can be viewed as an icon, an expandable node, or an expanded 
node.  The different views merely depend on user preference and do not change the 
functionality of the subVI.
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SubVIs

• A SubVI is a VI that can be used within another VI

• Similar to a subroutine
• Advantages

– Modular

– Easier to debug

– Don’t have to recreate code
– Require less memory

After you build a VI and create its icon and connector pane, you can use it in 
another VI. A VI within another VI is called a subVI. A subVI corresponds to a 
subroutine in text-based programming languages. Using subVIs helps you 
manage changes and debug the block diagram quickly.
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Icon and Connector

• An icon represents a VI in other block 

diagrams

• A connector shows available 

terminals for data transfer

Icon

Connector

Terminals

Every VI displays an icon, shown above, in the upper right corner of the front 
panel and block diagram windows. An icon is a graphical representation of a VI. 
It can contain text, images, or a combination of both. If you use a VI as a subVI, 
the icon identifies the subVI on the block diagram of the VI.

The connector shows terminals available for transfer or data to and from the 
subVI. There are several connector patterns to choose from. Right click on the 
connector and select the pattern from the Patternsmenu. From there you can 
assign controls and indicators on the front panel to the connector terminal, as we 
will see later.
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SubVIs Sub VIsSub VIs

The above block diagram contains two subVIs. To see the front panel of a 
subVI, simply double click the subVI. You can also view the hierarchy of 
subVIs within a top level VI by clicking on Browse » Show VI Hierarchy.
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Steps to Create a SubVI

• Create the Icon

• Create the Connector

• Assign Terminals

• Save the VI

• Insert the VI into a Top Level VI
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Create the Icon

• Right-click on the icon in the 
block diagram or front panel

Create custom icons to replace the default icon by right-clicking the icon in the 
upper right corner of the front panel or block diagram and selecting Edit Icon 
from the shortcut menu or by double-clicking the icon in the upper right corner 
of the front panel. You also can edit icons by selecting File»VI Properties, 
selecting General from the Category pull-down menu, and clicking the Edit 
Icon button. Use the tools on the left side of the Icon Editor dialog box to 
create the icon design in the editing area. The normal size image of the icon 
appears in the appropriate box to the right of the editing area.

You also can drag a graphic from anywhere in your file system and drop it in the 
upper right corner of the front panel or block diagram. LabVIEW converts the 
graphic to a 32 × 32 pixel icon.
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Create the Connector

Right click on the icon pane (front panel only)

To use a VI as a subVI, you need to build a connector pane. The connector pane 
is a set of terminals that corresponds to the controls and indicators of that VI, 
similar to the parameter list of a function call in text-based programming 
languages. The connector pane defines the inputs and outputs you can wire to 
the VI so you can use it as a subVI.

Define connections by assigning a front panel control or indicator to each of the 
connector pane terminals. To define a connector pane, right-click the icon in the 
upper right corner of the front panel window and select Show Connector from 
the shortcut menu. The connector pane replaces the icon. Each rectangle on the 
connector pane represents a terminal. Use the rectangles to assign inputs and 
outputs. The number of terminals LabVIEW displays on the connector pane 
depends on the number of controls and indicators on the front panel. The above 
front panel has four controls and one indicator, so LabVIEW displays four input 
terminals and one output terminal on the connector pane.
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Assign Terminals

After you select a pattern to use for your connector pane, you must define 
connections by assigning a front panel control or indicator to each of the 
connector pane terminals. When you link controls and indicators to the 
connector pane, place inputs on the left and outputs on the right to prevent 
complicated, unclear wiring patterns in your VIs. To assign a terminal to a front 
panel control or indicator, click a terminal of the connector pane. Click the front 
panel control or indicator you want to assign to the terminal. Click an open area 
of the front panel. The terminal changes to the data type color of the control to 
indicate that you connected the terminal. You also can select the control or 
indicator first and then select the terminal.

Make sure you save the VI after you have made the terminal assignments.
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Save The VI

• Choose an Easy to Remember Location

• Organize by Functionality
– Save Similar VIs into one directory (e.g. Math Utilities)

• Organize by Application
– Save all VIs Used for a Specific Application into one 

directory  or library file (e.g. Lab 1 – Frequency 
Response)

• Library Files (.llbs) combine many VI’s into a single file, ideal for 
transferring entire applications across computers

There are several ways to organize your subVIs. The most common way is to 
organize by application. In this case, all the VI’s for a particular application are 
saved into the same directory or into a VI Library file. Saving into a library file 
allows you to transport an entire application within a single file.

Saving into library is simple. After clicking Save As…, click New VI Library. 
This will allow you to name the library, and then save your VI into it. To add 
subsequent VI’s, simply double click the .llb file from the standard Save 
window, and give the VI a name.
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Insert the SubVI into a Top Level VI

Accessing user-made subVIs
Functions >>All Functions >> Select a VI

Or  
Drag icon onto target diagram

After you build a VI and create its icon and connector pane, you can use it as a 
subVI. To place a subVI on the block diagram, select Functions»Select a VI. 
Navigate to and double-click the VI you want to use as a subVI and place it on 
the block diagram.

You also can place an open VI on the block diagram of another open VI by 
using the Positioning tool to click the icon in the upper right corner of the front 
panel or block diagram of the VI you want to use as a subVI and drag the icon to 
the block diagram of the other VI.
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Tips for Working in LabVIEW

• Keystroke Shortcuts
– <Ctrl-H> – Activate/Deactivate Context Help Window

– <Ctrl-B> – Remove Broken Wires From Block Diagram

– <Ctrl-E> – Toggle Between Front Panel and Block 
Diagram

– <Ctrl-Z> – Undo (Also in Edit Menu)

• Tools » Options… – Set Preferences in LabVIEW

• VI Properties – Configure VI Appearance, 
Documentation, etc.

LabVIEW has many keystroke shortcuts that make working easier. The most 
common shortcuts are listed above.

While the Automatic Selection Tool is great for choosing the tool you would 
like to use in LabVIEW, there are sometimes cases when you want manual 
control. Use the Tab key to toggle between the four most common tools 
(Operate Value, Position/Size/Select, Edit Text, Set Color on Front Panel and 
Operate Value, Position/Size/Select, Edit Text, Connect Wire on Block 
Diagram). Once you are finished with the tool you choose, you can press <Shift-
Tab> to turn the Automatic Selection Tool on.

In the Tools » Options… dialog, there are many configurable options for 
customizing your Front Panel, Block Diagram, Colors, Printing, and much 
more.

Similar to the LabVIEW Options, you can configure VI specific properties by 
going to File » VI Properties… There you can document the VI, change the 
appearance of the window, and customize it in several other ways.
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Section III – Data Acquisition

• Data acquisition (DAQ) basics

• Connecting Signals

• Simple DAQ application

Computer

DAQ Device

Terminal Block

Cable

Sensors
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Data Acquisition in LabVIEW

Traditional NI-DAQ

Specific VIs for 

performing:

• Analog Input

• Analog Output

• Digital I/O

• Counter operations

NI-DAQmx

Next generation driver: 

• VIs for performing a 

task

• One set of VIs for all 

measurement types

The Data Acquisition palette in LabVIEW contains a palette for traditional NI-DAQ 
and one for NI-DAQmx.

Traditional VIs are divided by the type of measurement; DAQmx VIs are divided by the 
type of task.

You must complete several steps before you can use the Data Acquisition VIs. The 
devices should be configured for the computers in this class.

1. NI-DAQ software must be installed on the computer

2. You must have installed an E-series DAQ board and configured it using 
Measurement & Automation Explorer (MAX).

For more information on installing and configuring National Instruments hardware, 
consult the DAQ Quick Start Guide:

http://digital.ni.com/manuals.nsf/websearch/E502277FE33ED60686256B3B0056AEDF
?OpenDocument&node=132100_US
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DAQ – Data Acquisition

Temperature Acquisition using the DAQ Assistant

Above is the DAQ Assistant window that can be quickly configured to read 
temperature from a Data Acquisition (DAQ) board.
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Data Acquisition Terminology

•Resolution - Determines How Many Different Voltage 

Changes Can Be Measured

– Larger Resolution � More Precise Representation of Signal

•Range - Minimum and Maximum Voltages

– Smaller range � More Precise Representation of Signal

•Gain - Amplifies or Attenuates Signal for Best Fit in 

Range

Resolution: When acquiring data to a computer, an Analog-to-Digital Converter 
(ADC) takes an analog signal and turns it into a binary number. Therefore, each 
binary number from the ADC represents a certain voltage level.  The ADC 
returns the highest possible level without going over the actual voltage level of 
the analog signal. Resolution refers to the number of binary levels the ADC can 
use to represent a signal. To figure out the number of binary levels available 
based on the resolution you simply take 2Resolution.  Therefore, the higher the 
resolution, the more levels you will have to represent your signal.  For instance, 
an ADC with 3-bit resolution can measure 23 or 8 voltage levels, while an ADC 
with 12-bit resolution can measure 212 or 4096 voltage levels.

Range:Unlike the resolution of the ADC, the range of the ADC is selectable.  
Most DAQ devices offer a range from 0 - +10 or -10 to +10.  The range is 
chosen when you configure your device in NI-DAQ. Keep in mind that the 
resolution of the ADC will be spread over whatever range you choose.  The 
larger the range, the more spread out your resolution will be, and you will get a 
worse representation of your signal.  Thus it is important to pick your range to 
properly fit your input signal.
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Gain: Properly choosing the range of your ADC is one way to make sure you 
are maximizing the resolution of your ADC.  Another way to help your signal 
maximize the resolution of the ADC is by applying a gain.  Gain refers to any 
amplification or attenuation of a signal. The gain setting is a scaling factor. Each 
voltage level on your incoming signal is multiplied by the gain setting to 
achieve the amplified or attenuated signal. Unlike resolution that is a fixed 
setting of the ADC, and range that is chosen when the DAQ device is 
configured, the gain is specified indirectly through a setting called input limits.  
Input limits refers to the minimum and maximum values of your actual analog 
input signal. Based on the input limits you set, the largest possible gain is 
applied to your signal that will keep the signal within the chosen range of the 
ADC.  So instead of needing to calculate the best gain based on your signal and 
the chosen range, all you need to know is the minimum and maximum values of 
your signal. 
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Hardware Connections

BNC-2120

SCB-68

NI-ELVIS

SC-2075

There are many different hardware setups possible when acquiring data. All 
Data Acquisition systems require some sort of connection terminal that accepts 
a signal from your transducer and transmits it to the DAQ card. Four such 
terminal blocks are the BNC-2120, SC-2075, SCB-68, and NI-ELVIS.

The BNC-2120 is a shielded connector block with signal-labeled BNC 
connectors for easy connectivity to your DAQ device. It also provides a function 
generator, quadrature encoder, temperature reference, thermocouple connector, 
and LED so that you can test the functionality of your hardware.

The SC-2075 provides breadboard area for prototyping and BNC and spring
terminal connectivity. The built-in ±15 V or adjustable 0 to 5 V power supply 
and LED’s make the SC-2075 ideal for academic laboratories.

The SCB-68 is a shielded I/O connector block for rugged, very low-noise signal 
termination. It includes general-purpose breadboard areas (two) as well as an IC 
temperature sensor for cold-junction compensation in temperature 
measurements.

NI-ELVIS (Educational Laboratory Virtual Instrumentation Suite) is a 
LabVIEW-based design and prototyping environment and consists of 
LabVIEW-based virtual instruments, a multifunction data acquisition device, 
and a custom-designed bench-top workstation and prototyping board. 
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Exercise 2 – Simple Data Acquisition

Complete Convert C to F.vi, then create Thermometer.vi.

Note: To complete this exercise, you will need the IC temperature sensor 
available on either the BNC-2120, SCB-68 or DAQ Signal Accessory.

Estimated completion time: 30 minutes.

Instructions: This exercise has three parts.

First, create an icon and connector for Convert C to F.vi (Exercise 1). The icon 
should remind you of the functionality of the VI (e.g. C�F or CtoF). The 
connector should have one input and one output, allowing a terminal for °C in, 
and °F out.

Second, create a top level VI that acquires a data point from channel 0 (the 
temperature sensor) of your DAQ board and allows the user to display the 
temperature in Celsius or Fahrenheit. To do this you will need to acquire a 
single data point from your DAQ board and scale it by a factor of 100. This will 
give you °C. You should have a Boolean switch or button that allows the user to 
select Celsius or Fahrenheit. If the user selects Celsius, the scaled value should 
be displayed in a thermometer indicator. If the user selects Fahrenheit, the 
Celsius value should be passed into Convert C to F.vi (used as a subVI), and the 
output Fahrenheit value should be displayed.

Hint: Use the Selectfunction in the Comparisonpalette.
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Finally, create an Icon and Connector for Thermometer.vi. One possible Icon 
would be a picture of a thermometer. The connector should have two terminals. 
One for the Boolean input (°C or °F), and the second for the scaled temperature 
output. Save the VI as Thermometer.vi.
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Section IV – Loops and Charts

• For Loop

• While Loop
• Charts

• Multiplots
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Loops

• While Loops
– Have Iteration Terminal
– Always Run at least Once

– Run According to Conditional 
Terminal

• For Loops
– Have Iteration Terminal
– Run According to input N of 

Count Terminal

Both the While and For Loops are located on the Functions»Structures palette. 
The For Loop differs from the While Loop in that the For Loop executes a set 
number of times. A While Loop stops executing the subdiagram only if the 
value at the conditional terminal exists.

While Loops

Similar to a Do Loop or a Repeat-Until Loop in text-based programming 
languages, a While Loop, shown at the top right, executes a subdiagram until a 
condition is met. The While Loop executes the sub diagram until the conditional 
terminal, an input terminal, receives a specific Boolean value. The default 
behavior and appearance of the conditional terminal is Continue If True , 
shown at left. When a conditional terminal is Continue If True , the While Loop 
executes its subdiagram until the conditional terminal receives a FALSE value. 
The iteration terminal (an output terminal), shown at left, contains the number 
of completed iterations. The iteration count always starts at zero. During the 
first iteration, the iteration terminal returns 0.

For Loops

A For Loop, shown at left, executes a subdiagram a set number of times. The 
value in the count terminal (an input terminal) represented by the N, indicates 
how many times to repeat the subdiagram. The iteration terminal (an output 
terminal), shown at left, contains the number of completed iterations. The 
iteration count always starts at zero. During the first iteration, the iteration 
terminal returns 0.
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Loops (cont.)
1. Select the loop 2. Enclose code to be repeated

3. Drop or drag additional nodes and then wire

Place loops in your diagram by selecting them from the Structures palette of the 
Functions palette (demonstrate):

When selected, the mouse cursor becomes a special pointer that you use to 
enclose the section of code you want to repeat.

Click the mouse button to define the top-left corner, click the mouse button 
again at the bottom-right corner, and the While Loop boundary is created around 
the selected code.

Drag or drop additional nodes in the While Loop if needed.
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Charts

Waveform chart – special 
numeric indicator that can 
display a history of values

Controls >> Graph Indicators 
>>  Waveform Chart

The waveform chart is a special numeric indicator that displays one or more 
plots. The waveform chart is located on the Controls»Graph Indicators 
palette. Waveform charts can display single or multiple plots. The following 
front panel shows an example of a multi-plot waveform chart.

You can change the min and max values of either the x or y axis by double 
clicking on the value with the labeling tool and typing the new value. Similarly, 
you can change the label of the axis. You can also right click the plot legend and 
change the style, shape, and color of the trace that is displayed on the chart.
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Wiring Data into Charts

Single Plot Charts Multiplot Charts

You can wire a scalar output directly to a waveform chart to display one plot.  
To display multiple plots on one chart, use the Merge Signalsfunction found in 
the Functions >> Signal Manipulationpalette.  The Merge Signalfunction 
bundles multiple outputs to plot on the waveform chart. To add more plots, use 
the Positioning tool to resize the Merge Signalfunction.

The context help contains very good information on how the different ways to 
wire data into charts.
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Exercise 3 – Using loops 

Students build Use a loop.vi.

This exercise should take 15-20 minutes.

Instructions:

Create a VI that generates a random number at a specified rate and displays the 
readings on a Waveform Chart until stopped by the user.  Connect the 
termination terminal to a front panel stop button, and add a slider control to the 
front panel. The slider control should range from 0 to 2000 in value, and be 
connected to the Time Delay Express VI function inside your while loop. Save 
the VI as Use a loop.vi.
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Section V – Arrays & File I/O

• Build arrays manually
• Have LabVIEW build arrays automatically

• Write to a spreadsheet file
• Read from a spreadsheet file

Arrays group data elements of the same type. An array consists of elements and 
dimensions. Elements are the data that make up the array. A dimension is the 
length, height, or depth of an array. An array can have one or more dimensions 
and as many as 2^31 – 1 elements per dimension, memory permitting.

You can build arrays of numeric, Boolean, path, string, waveform, and cluster 
data types. Consider using arrays when you work with a collection of similar 
data and when you perform repetitive computations. Arrays are ideal for storing 
data you collect from waveforms or data generated in loops, where each 
iteration of a loop produces one element of the array.

Array elements are ordered. An array uses an index so you can readily access 
any particular element. The index is zero-based, which means it is in the range 0 
to n – 1, where n is the number of elements in the array. For example, n = 9 for 
the nine planets, so the index ranges from 0 to 8. Earth is the third planet, so it 
has an index of 2.

File I/O operations pass data to and from files. Use the File I/O VIs and 
functions located on the Functions » File I/O palette to handle all aspects of file 
I/O. In this class we will cover reading and writing spreadsheet files using the 
Express VIs for File I/O.
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Adding an Array to the Front Panel

From the Controls >> All Controls >> Array and 
Cluster subpalette, select the Array Shell

Drop it on the screen.

To create an array control or indicator as shown, select an array on the 
Controls»All Controls»Array & Cluster palette, place it on the front panel, 
and drag a control or indicator into the array shell. If you attempt to drag an 
invalid control or indicator such as an XY graph into the array shell, you are 
unable to drop the control or indicator in the array shell.

You must insert an object in the array shell before you use the array on the block 
diagram. Otherwise, the array terminal appears black with an empty bracket.
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Adding an Array (cont.)

Place data object into shell (i.e. Numeric Control)

To add dimensions to an array one at a time, right-click the index display and 
select Add Dimension from the shortcut menu. You also can use the Positioning 
tool to resize the index display until you have as many dimensions as you want.
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Creating an Array with a Loop

• Loops accumulate arrays at their boundaries

If you wire an array to a For Loop or While Loop input tunnel, you can read and 
process every element in that array by enabling auto-indexing. When you auto-
index an array output tunnel, the output array receives a new element from 
every iteration of the loop. The wire from the output tunnel to the array indicator 
becomes thicker as it changes to an array at the loop border, and the output 
tunnel contains square brackets representing an array, as shown in the following 
illustration.

Disable auto-indexing by right-clicking the tunnel and selecting Disable 
Indexing from the shortcut menu. For example, disable auto-indexing if you 
need only the last value passed to the tunnel in the previous example, without 
creating an array.

Note Because you can use For Loops to process arrays an element at a 
time, LabVIEW enables auto-indexing by default for every array you 
wire to a For Loop. Auto-indexing for While Loops is disabled by 
default. To enable auto-indexing, right-click a tunnel and select Enable 
Indexing from the shortcut menu.

If you enable auto-indexing on an array wired to a For Loop input terminal, 
LabVIEW sets the count terminal to the array size so you do not need to wire 
the count terminal. If you enable auto-indexing for more than one tunnel or if 
you wire the count terminal, the count becomes the smaller of the choices. For 
example, if you wire an array with 10 elements to a For Loop input tunnel and 
you set the count terminal to 15, the loop executes 10 times.
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Creating 2D Arrays

You can use two For Loops, one inside the other, to create a 2D array. The outer 
For Loop creates the row elements, and the inner For Loop creates the column 
elements.
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File I/O

File I/O – passing data to and from files
- Files can be binary, text, or spreadsheet

- Write/Read LabVIEW Measurements file (*.lvm)

Writing to LVM fileWriting to LVM file Reading from LVM fileReading from LVM file

File I/O operations pass data to and from files. In LabVIEW, you can use File 
I/O functions to:

Open and close data files

Read data from and write data to files

Read from and writ to spreadsheet-formatted files

Move and rename files and directories

Change file characteristics

Create, modify, and read a configuration file

Write to or read from LabVIEW Measurements files.

In this course we will examine how to write to or read from LabVIEW 
Measurements files (*.lvm files).   
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Write LabVIEW Measurement File

• Includes the open, write, close and error handling functions 

• Handles formatting the string with either a tab or comma 

delimiter 

• Merge Signals function is used to combine data into the 

dynamic data type

The Write LVM file can write to spreadsheet files.  However, its main purpose is for 
logging data, that will be used in LabVIEW. This VI creates a .lvm file which can be 
opened in a spreadsheet application.  For simple spreadsheet files, use the Express 
VIs: Write LVM and Read LVM.
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Exercise 4 – Analyzing and Logging Data

Students build Temperature Logger.vi

Estimated completion time: 30-45 minutes.

Instructions:

Create a VI that acquires and displays temperature data at a fixed rate until 
stopped by the user. If you have completed Exercise 2 and have a DAQ card, use 
Thermometer.vi to obtain your data. If you have not completed the exercise or do 
not have a DAQ card, you can use the Digital Thermometer.vi from the Tutorial 
subpalette of the functions palette.

Once stopped, the VI should perform analysis on the data it collected while 
running. Build up an array of data points and values on the tunnel border of the 
while loop. Find the maximum, minimum, and mean value of the temperature 
data and display them in numeric indicators (the mean function can be found in 
Functions»Analyze»Mathematics»Probability and Statistics, and the Array 
Max & Min function can be found in Functions»Array) . Use the Write 
LabVIEW Measurements File Express VI, which can be found at 
Functions»Output. Once it is run, verify that the file was properly created by 
opening it in Notepad or by creating a VI that reads it back using the Read 
LabVIEW Measurements File. When you have completed the exercise, save your 
VI as Temperature Logger.vi.
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Section VI – Array Functions & Graphs

• Basic Array Functions
• Use graphs

• Create multiplots with graphs
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Array Functions – Basics

Functions >> All functions>> ArrayFunctions >> All functions>> Array

Use the Array functions located on the Functions»All Functions»Array palette 
to create and manipulate arrays. Array functions include the following:

•Array Size—Returns the number of elements in each dimension of an array. If
the array is n-dimensional, the size output is an array of n elements.

•Initialize Array —Creates an n-dimensional array in which every element is 
initialized to the value of element. Resize the function to increase the number of 
dimensions of the output array. 

•Build Array —Concatenates multiple arrays or appends elements to an n-
dimensional array. Resize the function to increase the number of elements in the 
output array. 

•Array Subset—Returns a portion of an array starting at index and containing 
length elements. 

•Index Array —Returns an element of an array at index. You also can use the 
Index Array function to extract a row or column of a 2D array to create a 
subarray of the original. To do so, wire a 2D array to the input of the function. 
Two index terminals are available. The top index terminal indicates the row, 
and the second terminal indicates the column. You can wire inputs to both index 
terminals to index a single element, or you can wire only one terminal to extract 
a row or column of data. For example, wire the following array to the input of 
the function.
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Array Functions – Build Array

Build Array can perform two distinct functions. It Concatenates multiple arrays 
or appends elements to an n-dimensional array. Resize the function to increase 
the number of elements in the output array. To concatenate the inputs into a 
longer array of the same dimension as shown in the following array, right-click 
the function node and select Concatenate Inputs from the shortcut menu.
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Graphs

• Selected from the Graph palette of Controls menu
Controls>>All Controls>>Graphs

Waveform GraphWaveform Graph–– Plot an array of Plot an array of 
numbers against their indicesnumbers against their indices
Express XY GraphExpress XY Graph–– Plot one array Plot one array 
against anotheragainst another
Digital Waveform GraphDigital Waveform Graph–– Plot bits Plot bits 
from binary datafrom binary data

VIs with graphs usually collect the data in an array and then plot the data to the 
graph.

The graphs located on the Controls» All Controls» Graph palette include the 
waveform graph and XY graph. The waveform graph plots only single-valued 
functions, as in y = f(x), with points evenly distributed along the x-axis, such as 
acquired time-varying waveforms. Express XY graphs display any set of points, 
evenly sampled or not. Resize the plot legend to display multiple plots. Use 
multiple plots to save space on the front panel and to make comparisons 
between plots. XY and waveform graphs automatically adapt to multiple plots.

Single-Plot Waveform Graphs

The waveform graph accepts a single array of values and interprets the data as 
points on the graph and increments the x index by one starting at x = 0. The 
graph also accepts a cluster of an initial x value, a .x, and an array of y data. 
Refer to the Waveform Graph VI in the examples\general\graphs\gengraph.llb 
for examples of the data types that single-plot waveform graphs accept.
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Multiple-Plot Waveform Graphs

A multiplot waveform graph accepts a 2D array of values, where each row of 
the array is a single plot. The graph interprets the data as points on the graph and 
increments the x index by one, starting at x = 0. Wire a 2D array data type to the 
graph, right-click the graph, and select Transpose Array from the shortcut 
menu to handle each column of the array as a plot. Refer to the (Y) Multi Plot 1 
graph in the Waveform Graph VI in the examples\general\graphs\gengraph.llb 
for an example of a graph that accepts this data type.

A multiplot waveform graph also accepts a cluster of an x value, a ∆x value, and 
a 2D array of y data. The graph interprets the y data as points on the graph and 
increments the x index by ∆x, starting at x = 0. Refer to the (Xo, ∆x, Y) Multi 
Plot 3 graph in the Waveform Graph VI in the 
examples\general\graphs\gengraph.llb for an example of a graph that accepts 
this data type.

A multiplot waveform graph accepts a cluster of an initial x value, a .x value, 
and an array that contains clusters. Each cluster contains a point array that 
contains the y data. You use the Bundle function to bundle the arrays into 
clusters, and you use the Build Array function to build the resulting clusters into 
an array. You also can use the Build Cluster Array, which creates arrays of 
clusters that contain inputs you specify. Refer to the (Xo, ∆x, Y) Multi Plot 2 
graph in the Waveform Graph VI in the examples\general\graphs\gengraph.llb 
for an example of a graph that accepts this data type.

Single-Plot XY Graphs

The single-plot XY graph accepts a cluster that contains an x array and a y array. 
The XY graph also accepts an array of points, where a point is a cluster that 
contains an x value and a y value. Refer to the XY Graph VI in the 
examples\general\graph\gengraph.llb for an example of single-plot XY graph 
data types.

Multiplot XY Graphs
The multiplot XY graph accepts an array of plots, where a plot is a cluster that 
contains an x array and a y array. The multiplot XY graph also accepts an array 
of clusters of plots, where a plot is an array of points. A point is a cluster that 
contains an x value and a y value. Refer to the XY Graph VI in the 
examples\general\graph\gengraph.llb for an example of multiplot XY graph data 
types.
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Graphs

Right-Click on the Graph and choose Properties
to Interactively Customize

Graphs are very powerful indicators in LabVIEW. The can are highly 
customizable, and can be used to concisely display a great deal of information.

The properties page of the Graph allows you to display settings for plot types, 
scale and cursor options, and many other features of the graph. 
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Exercise 5 – Using Waveform Graphs

Estimated Completion Time: 20 minutes.

Create a VI like the one pictured above. The VI should use a while loop with a 
100 millisecond delay to continuously generate sine and square waves and 
display them on a waveform graph. Use Simulate Signal Express VI from the 
Functions»Input palette to generate the signals. The frequency input to each 
function is chosen by the user

Change the colors, visible items, and plot styles of the graph. Experiment with 
some of the cursor and zooming options available.
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Section VII – Strings, Clusters, & Error Handling

•Strings

•Creating Clusters

•Cluster Functions

•Error I/O
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Strings

• A string is a sequence of displayable or nondisplayable 

characters (ASCII)

• Many uses – displaying messages, instrument control, file 

I/O

• String control/indicator is in the Controls »Text Control or 

Text Indicator

A string is a sequence of displayable or nondisplayable (ASCII) characters. 
Strings often are used to send commands to instruments, to supply information 
about a test (such as operator name and date), or to display results to the user.

String controls and indicators are in theText Control or Text Indicator 
subpalette of the Controls palette.
•Enter or change text by using the Operating or Text tool and clicking in the 
string control.
•Strings are resizable.
•String controls and indicators can have scrollbars: Right-click and select 
Visible Items » Scrollbar. The scroll bar will not be active if the control or 
indicator is not tall enough.
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Clusters

• Data structure that groups data together

• Data may be of different types

• Analogous to struct in C

• Elements must be either all controls or all indicators

• Thought of as wires bundled into a cable

Clusters group like or unlike components together.

Equivalent to a record in Pascal or a struct in C.

Cluster components may be of different data types.

Examples:

Error information—Grouping a Boolean error flag, a numeric error code, 
and an error source string to specify the exact error.

User information—Grouping a string indicating a user’s name and an ID 
number specifying their security code.

All elements of a cluster must be either controls or indicators. You cannot have 
a string control and a Boolean indicator. 

Clusters can be thought of as grouping individual wires (data objects) together 
into a cable (cluster).
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Creating a Cluster

1. Select a Cluster shell

Controls >> All Controls >> Array & Cluster

2. Place objects inside the shell

Demonstrate how to create a cluster front panel object by choosing Cluster
from the Controls»All Controls»Array & Cluster palette.

•This option gives you a shell (similar to the array shell when creating arrays).

•You can size the cluster shell when you drop it.

•Right click inside the shell and add objects of any type. 

Note: You can even have a cluster inside of a cluster.

The cluster becomes a control or an indicator cluster based on the first object 
you place inside the cluster.

You can also create a cluster constant on the block diagram by choosing Cluster 
Constant from the Cluster palette.

•This gives you an empty cluster shell.

•You can size the cluster when you drop it.

•Put other constants inside the shell.

Note: You cannot place terminals for front panel objects in a cluster constant 
on the block diagram, nor can you place “special” constants like the Tab or 
Empty String constant within a block diagram cluster shell.
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Cluster Functions
• In the Cluster subpalette of the Functions>>All 

functions palette
• Can also be accessed by right-clicking on the cluster 

terminal

Bundle

(Terminal labels 
reflect data type)

Bundle By Name

Bundle function—Forms a cluster containing the given objects (explain the 
example).

Bundle by Name function—Updates specific cluster object values (the object 
must have an owned label). 

Note: You must have an existing cluster wired into the middle terminal of the 
function to use Bundle By Name.
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Cluster Functions

Unbundle

Unbundle By Name

Unbundled cluster 
in the diagram

Unbundle function—Use to access all of the objects in the cluster.

Unbundle by Name function—Use to access specific objects (one or more) in 
the cluster. 

Note: Only objects in the cluster having an owned label can be accessed. 
When unbundling by name, click on the terminal with the Operating tool to 
choose the element you want to access.

The Unbundle function must have exactly the same number of terminals as 
there are elements in the cluster. Adding or removing elements to the cluster 
breaks wires on the diagram.

You can also obtain the Bundle, Unbundle, Bundle by Name, and Unbundle 
by Name functions by right clicking on the cluster terminal in the diagram and 
choosing Cluster Tools from the pop-up menu. When you choose Cluster 
Tools, the Bundle and Unbundle functions automatically contain the correct 
number of terminals. The Bundle by Name and Unbundle by Namefunctions 
appear with the first cluster element.
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Error Clusters

• Error cluster contains the following information:
–Boolean to report whether error occurred
–Integer to report a specific error code
–String to give information about the error

Error clusters are a powerful means of handling errors.

The LabVIEW DAQ VIs, File I/O functions, networking VIs, and many other 
VI’s use this method to pass error information between nodes.

The error cluster contains the following elements:

•status, a Boolean which is set to True if an error occurs.

•code, a numeric which is set to a code number corresponding to the 
error that occurred.

•source, a string which identifies the VI in which the error occurred.
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Error Handling Techniques

• Error information is passed from one subVI to the next
• If an error occurs in one subVI, all subsequent subVIs are 

not executed in the usual manner
• Error Clusters contain all error conditions
• Automatic Error Handling

error clusters

Error clusters are useful in determining the execution of subVIs when an error is 
encountered.

Note also that error clusters can be useful in determining program flow due to 
the dataflow programming paradigm.  This can be especially useful when 
setting up sampling on more than one DAQ board simultaneously.

The unbundle by name function shows the components of an error cluster.
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Section VIII - Case & Sequence Structures, 

Formula Nodes
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Case Structures

• In the Structures subpalette of Functions palette
• Enclose nodes or drag them inside the structure
• Stacked like a deck of cards, only one case visible

Functions >> Execution control

The Case structure allows you to choose a course of action 
depending on an input value.
In the Execution Control subpalette of the Functionspalette.
Analogous to an if-then-else statement in other languages. 
Like a deck of cards. You can see only one case at a time. 
•Example 1: Boolean input: Simple if-then case. If the Boolean input 
is TRUE, the true case will execute; otherwise the FALSE case will 
execute. 
•Example 2: Numeric input. The input value determines which box 
to execute. If out of range of the cases, LabVIEW will choose the 
default case.
•Example 3: String input. Like the numeric input case, the value of 
the string determines which box to execute. Stress that the value 
much match exactly or the structure will execute the default case.



73

Exercise 6 – Error Clusters & Handling

Estimated Completion Time: 20 minutes.

Create a VI that takes the square root of a number. If the number is greater than 
or equal to zero, the VI should return its square root, and generate no error. If 
the number is less than zero, the VI should return the value -9999.90, and insert 
an error into the error cluster.

Use a Case structurefrom the and the Greater or Equal To 0? function from 
the numeric palette to determine whether the VI will compute the square root or 
generate the error. The “False” case shown above is the error case. Use a 
Bundle By Namefunction from the cluster palette to insert a Boolean, Numeric,
and String Constant into the Status, Code, and Source cluster items, 
respectively. The values of the constants should be True, 5008 (an arbitrary user 
defined error code), and “Square Root.vi” (the name of the VI that generated the 
error). Wire the new cluster into the Error Out indicator, and a constant value of 
-9999.90 to the Square Root indicator. The True case, not shown, should merely 
wire the error in control directly through the case to the error out indicator. The 
Square Root Input should be wired to the Square Rootfunction from the 
numeric palette, and the result should be wired out of the case into the Square 
Root indicator.

Point out that this VI could be easily configured as a subVI for a larger piece of 
code, and troubleshooting and debugging is much easier when errors clusters are 
properly used.
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Sequence Structures

• In the Execution Control subpalette of Functions palette
• Executes diagrams sequentially
• Right-click to add new frame

In a text-based language, program statements execute in the order in which they 
appear. In data flow, a node executes when data is available at all its input 
terminals.
Sometimes it is hard to tell the exact order of execution. Often, certain events 
must take place before other events. When you need to control the order of 
execution of code in your block diagram, you can use a sequence structure.
Sequence structure: Used to control the order in which nodes in a diagram will 
execute.
In theExecution Control subpalette.

•Looks like a frame of film.
•Used to execute diagrams sequentially.
•Right-click on the border to create a new frame.
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Formula Nodes

• In the Structures subpalette 
• Implement complicated equations
• Variables created at border
• Variable names are case sensitive
• Each statement must terminate with a semicolon (;)
• Context Help Window shows available functions

Note semicolon

Sometimes it is preferable to program mathematical expressions with text-based 
function calls, rather than icons (which can take up a lot of room on the 
diagram). 
Formula Node: allows you to implement complicated equations using text-
based instructions.

•Located in the Structures subpalette.
•Resizable box for entering algebraic formulas directly into block 
diagrams.
•To add variables, right-click and choose Add Input or Add Output . 
Name variables as they are used in formula. (Names are case sensitive.) 
•Statements must be terminated with a semicolon.
•When using several formulas in a single formula node, every assigned 
variable (those appearing on the left hand side of each formula) must 
have an output terminal on the formula node. These output terminals do 
not need to be wired, however.

Compare the examples on the slide.
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Section IX – Printing & Documentation

• Print From File Menu to Printer, HTML, Rich Text File

• Programmatically Print Graphs or Front Panel Images

• Document VIs in VI Properties » Documentation Dialog

• Add Comments Using Free Labels on Front Panel & 

Block Diagram
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Printing

• File » Print… Gives Many Printing Options

– Choose to Print Icon, Front Panel, Block Diagram, VI Hierarchy, 

Included SubVIs, VI History

• Print Panel.vi (Programmatically Prints a Front Panel) 

– Functions » All Functions » Application Control

• Generate & Print Reports (Functions » Output » Report)

LabVIEW offers many options for printing VIs. From the standard File »
Print… menu, the user can print a hard copy of his or her VI, or print the VI to a 
file for storage or publishing.

Using the Print Panel VI in LabVIEW allows the user to programmatically print 
the results of a test. VIs can also be configured to print automatically after 
execution. This option is set in VI Properties » Print Options.

For more advanced applications, LabVIEW has report generation tools that 
allow the user to create custom reports for individual applications.

LabVIEW 7.0 includes an Express VI called Report. This VI generates a 
preformatted report that contains VI documentation, data

the VI returns, and report properties, such as the author, company, and number 
of pages.
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Documenting VIs

• VI Properties » Documentation

– Provide a Description and Help Information for a VI

• VI Properties » Revision History

– Track Changes Between Versions of a VI

• Individual Controls » Description and Tip…

–Right Click to Provide Description and Tip Strip

• Use Labeling Tool to Document Front Panels & Block 

Diagrams

By opening a VI’s properties a developer can add documentation to his or her 
VI. The documentation placed in the Description field of the VI Documentation 
window shows up in Context Help, and prints with the VI.

If a user has an application that is continually developing, he or she can track 
changes in the development with Revision History, also found in VI Properties.

Any control or indicator on the Front Panel can be documented by right-clicking 
and choosing Description and Tip… The Description information appears in the 
Context Help menu when a user hovers the mouse over the object, and the Tip 
information pops up in a small strip next to the mouse when the user pauses 
above the object.

Much like comments in a text-based language, the developer may want to 
explain a portion of his code, or provide directions on a front panel. Either of 
these needs can be met by using the labeling tool to create a free text box with 
as many instructions or explanations as necessary.
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Section X – Basic Programming Architecture

• Simple VI Architecture

•General VI Architecture

• State Machine Architecture

You can structure VIs differently depending on what functionality you want 
them to have.  This section discusses some of the most common types of VI 
architectures, along with their advantages/disadvantages: simple, general, and 
state machines.
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Simple VI Architecture

• Functional VI that produces results when run

– No “start” or “stop” options

– Suitable for lab tests, calculations

• Example: Convert C to F.vi

Simple VI Architecture

When making quick lab measurements, you do not need a complicated 
architecture. Your program may consist of a single VI that takes a measurement, 
performs calculations, and either displays the results or records them to disk. 
The measurement can be initiated when the user clicks on the run arrow. 

In addition to being commonly used for simple applications, this architecture is 
used for “functional” components within larger applications. You can convert 
these simple VIs into subVIs that are used as building blocks for larger 
applications.
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General VI Architecture

• Three Main Steps
– Startup

– Main Application

– Shutdown

General VI Architecture

In designing an application, you generally have up to three main phases:

•Startup—Use this area to initialize hardware, read configuration information 
from files, or prompt the user for data file locations.

•Main Application—Generally consists of at least one loop that repeats until the 
user decides to exit the program, or the program terminates for other reasons 
such as I/O completion.

•Shutdown—This section usually takes care of closing files, writing 
configuration information to disk, or resetting I/O to its default state.

The diagram above shows this general architecture. 

For simple applications, the main application loop can be fairly straightforward.  
When you have complicated user interfaces or multiple events (user action, I/O 
triggers, and so on), this section can get more complicated.
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State Machine Architecture

• Advantages
– Can go from any state from any other
– Easy to modify and debug

• Disadvantages
– Can lose events if two occur at the 
same time

States:
0: Startup
1: Idle
2: Event 1
3: Event 2
4: Shutdown

State Machine VI Architecture
You can make your diagrams more compact by using a single case structure to 
handle all of your events.  In this model, you scan the list of possible events, or 
states, and then map that to a case.  For the VI shown above, the possible states 
are startup, idle, event 1, event 2, and shutdown.  These states are stored in an 
enumerated constant.  Each state has its own case where you place the 
appropriate nodes.  While a case is running, the next state is determined based 
on the current outcome.  The next state to run is stored in the shift register.  If an 
error occurs an any of the states, the shutdown case is called. 

The advantage of this model is that your diagram can become significantly 
smaller (left to right), making it easier to read and debug.  One drawback of the 
Sequence structure is that it cannot skip or break out of a frame.  This method 
solves that problem because each case determines what the next state will be as 
it runs.   

A disadvantage to this approach is that with the simple approach shown above, 
you can lose events.  If two events occur at the same time, this model handles 
only the first one, and the second one is lost.  This can lead to errors that are 
difficult to debug because they may occur only occasionally.  More complex 
versions of the state machine VI architecture contain extra code that builds a 
queue of events (states) so that you do not miss any events.
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Exercise 7 – Simple State Machine

Estimated Completion Time: 25 minutes.

In this exercise we will create a VI using state machine architecture. The VI will 
have an idle state, where it waits for input. When the user presses a button, the 
VI will go to State 1. State 1 will generate a pop-up dialog box that allows the 
sure to proceed to State 2 or start over. From State 2 the user can choose to exit 
the program or start over.

Rather than start from scratch, we will use a VI template to create our state 
machine. From the File menu, instead of selecting New VI,select New…, and 
click on Start from template. Browse to …\Program Files\National 
Instruments\LabVIEW 6.1\templates\State Machine.vit, and open it. This opens 
a template for a state machine using strings to control the state. Examine the 
template, and then save it in another directory before you begin working on it.

The first state we will make is the Initialize state. Notice this state has already 
been created for us, and is the default state. In the Initialize case, place a One 
Button Dialog (Functions » Time & Dialog), and wire “Initialized. Click OK to 
proceed.” into the message terminal. Replace the text “Next State” with “Idle”.
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Right click on the case structure and, choose Add Case After, and name the case 
“Idle”. Inside the Idle case, place a second case structure. Wire a Boolean called 
“Begin Test” to the select terminal for the inner case structure, and wire a string 
constant with the value “Test” out of the True case to the shift register. In the 
False case, wire the value “Idle” out to the shift register. This setup will keep the 
state machine in the Idle state until the user presses the button to begin the test. 
Right click on the Boolean output tunnel and choose Create » Constant. Set the 
constant value to True.

Right click on the main case structure and add another case. Call this case 
“Test”. In the Test case, place a Two Button Dialog (Functions » Time & 
Dialog). Wire the text “The test has run. Click OK to quit, Cancel to test again.”
into the message terminal. Place another case structure inside the Test case, and 
wire “T button?” the output of the Two Button Dialog into the selection 
terminal. Wire a value of “Idle” out of the False case into the shift register, and 
a Boolean True constant into the termination condition of the while loop. The 
True case should contain an empty string constant, and a Boolean False wired 
into the termination condition. This will terminate the program if the user 
presses OK, and return it back to the idle state if the user presses Cancel.
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Section XI – Remote Front Panels

• View & Control LabVIEW Front Panels from a Web 

Browser

• Requires no programming

•Remote clients see “live” front panel updates

•Multiple clients can view the same panel 

simultaneously

•Only one client can control the front panel at a time

In LabVIEW, a feature called remote front panels allow users to view and 
control the VI front panels remotely from LabVIEW or from a web browser 
without any programming. A user can run an application or check progress from 
anywhere. In addition, several users at different locations all can access the VI 
simultaneously.

Remote panel clients will see “live” updates to the VI front panel, as opposed to 
static images. There can be multiple clients simultaneously viewing the same 
front panel. However, only one client can control the front panel at a time.
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Remote Panel Web Publishing Tool

•Tools » Web Publishing Tool …

•Click Save to Disk 
and VI is embedded 
into an HTML file

•After file is saved, it 
can be reopened and 
customized in any 
HTML editor

To embed your VI into a web page, simply open the Web Publishing Tool from 
the Tools pull-down menu. The Web Publishing Tool creates a simple html file 
with the LabVIEW front panel embedded inside it. From the tool, you can create 
a title, and supply text before and after the front panel object. Once you have 
created the html file, you can preview it in a web browser, and save the file to 
disk. Saving the file places the html file in your LabVIEW www directory, 
which is the default directory for the LabVIEW web server. You can start the 
web server from the Web Publishing Tool, or from Tools » Options… » Web 
Server: Configuration. (Note: in the Tools » Options… menu you can also 
configure access rights and exposed VI’s for your web server.

If you would like to customize your web page beyond what the Web Publishing 
Tool provides, simply open the html file in another html editor, and customize 
around the embedded LabVIEW panel code.
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Remote Front Panels - Resources

• NI Developer Zone 

(zone.ni.com)

– Search for Remote Front 

Panel

– Tutorials & Instructions Are 

Available for Download

– Information on 

Incorporating Web 

Cameras into Remote 

Panel Applications

For more information on remote front panels, visit the NI Developer Zone, 
zone.ni.com.

Remote Panels in LabVIEW -- Distributed Application Development 

http://zone.ni.com/devzone/insights.nsf/2d17d611efb58b22862567a9006ffe76/8
bc90a5f744a482886256ba000681713?OpenDocument

Developing Remote Front Panel LabVIEW Applications

http://zone.ni.com/devzone/conceptd.nsf/2d17d611efb58b22862567a9006ffe76/
e789515b9976253786256b1f007e039b?OpenDocument



88

Section XII – Additional Topics

• Property Nodes

• Local Variables

•Global Variables

• DataSocket

• Binary File I/O

LabVIEW has many other tools available for your development. While time 
constraints don’t permit us to go into great detail, it is a good idea to highlight 
some of the advanced capabilities offered by LabVIEW. Students who are 
interested in a specific topic can search the LabVIEW Example Finder or visit 
NI’s Developer Zone for more information.

•Property Nodes – Properties are all the qualities of a front panel object.  With
property nodes, you can set or read such characteristics as foreground and 
background color, data formatting and precision, visibility, descriptive text, size 
and location on the front panel, and so on. Search for property nodes in the Find 
Examples window, there are 24 example programs that ship with LabVIEW.

•Local Variables – Local Variables break the dataflow programming paradigm, 
allowing data to be passed without wires. 

•Global Variables – A special kind of VI, used to store data in front panel 
objects for the purpose of data exchange between VI’s.

•DataSocket – A platform independent means of exchanging data between 
computers and applications, based on TCP-IP, but without the complexity of 
low level programming.

•Binary File I/O—allows a user to stream data to a disk in high speed 
applications.
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Where Do I Go From Here?

• Example programs (Help» Find Examples…)

• LabVIEW Student Edition (www.ni.com/labviewse)

•Web resources (ni.com)

–NI Developer Zone (zone.ni.com)

– Application Notes 

– Info-labview newsgroup (www.info-labview.org/)

– Instrument Driver Library (www.ni.com/idnet)

Where do you go from here?

•National Instruments offers a wide range of instructional courseware to expand 
your knowledge.  Please visit ni.com/academic for programs and resources 
available.
•The LabVIEW Student Edition is a available from our website. In includes 
Learning With LabVIEW, a textbook written by Dr. Bob Bishop from the 
University of Texas at Austin.
•The web is the best place to turn in order to find information on LabVIEW.  
Ni.com is designed to be the one stop resource to find information.  

•The NI Developer Zone (“NIDZ”) is a place for developers to meet, 
discuss design issues, and post content.
•Application Notes can be downloaded from ni.com/support on a variety 
of topics.
•Info-labview is a newsgroup maintained by a third party.
•There is an exhaustive library of LabVIEW instrument drivers available 
for download from NIDZ.


