RESEARCH REPORT

Linking Physical and Numerical Modelling in Hydrogeology using Sand Tank Experiments and COMSOL Multiphysics

Kamini Singha\textsuperscript{a}\textsuperscript{*} and Steven P. Loheide II\textsuperscript{b}

\textsuperscript{a}Department of Geosciences, Penn State University, Pennsylvania, USA; \textsuperscript{b}Department of Civil and Environmental Engineering, University of Wisconsin-Madison, Wisconsin, USA

Visualising subsurface processes in hydrogeology and building intuition for how these processes are controlled by changes in forcing is hard for many undergraduate students. While numerical modelling is one way to help undergraduate students explore outcomes of multiple scenarios, many codes are not user-friendly with respect to defining domains, boundary conditions, and coupling processes, and numerical modelling exercises are also often disconnected from systems that the students understand, limiting their ability to extrapolate what they have learned for other situations. Here, we test the hypothesis that hydrogeology students will better estimate rates of groundwater flow and contaminant transport and the magnitudes of the parameters that control flow and transport by linking physical and numerical models. We present an exercise that links physical and numerical modelling of fluid flow and solute transport using 2-D ‘ant farm’ sand tanks with parallel models in COMSOL Multiphysics. The sand tank exercises provide students with a way to visualise subsurface flow and transport processes, while COMSOL allows them to explicitly pull apart the mathematics associated with these systems and build intuition for their solutions. Given coupled experimentation and numerical exercises, we find that students will connect processes that they see in the laboratory with the outcomes of numerical models, and the post-exercise tests indicate that they have an improved understanding of: (1) the magnitude and importance of properties and parameters that control flow and transport and (2) the simplifications made in numerical models of physical systems.

Keywords: Hydrogeology; Numerical modelling; Fluid flow; Solute transport

\textsuperscript{*}Corresponding author. Department of Geosciences, Penn State University, 311 Deike Building, University Park, PA 16802, USA. Email: ksingha@psu.edu
Introduction

The geosciences are becoming increasingly mathematical (e.g. Macdonald & Bailey, 2000), and a critical issue in developing undergraduate students’ mathematical intuition of physical processes is allowing them to explore mathematical concepts in scenarios that extend beyond ‘plugging and chugging’ (Yuretich, 2003). The National Research Council has highlighted a number of difficulties with respect to engaging undergraduate students in science, including implementation of meaningful classroom experiences that provide students with a depth of understanding (National Research Council, 2000, 2005). Many students leave science because they view it as the rote memorisation of facts, rather than an understanding of important, applicable processes (Seymour & Hewitt, 1997). A solution to these problems is providing collaborative environments where students have the opportunity to link everyday problems with scientific training. Hydrogeology is a field that lends itself to applied problems; unfortunately, many of the systems of interest are subsurface, making visualisation of processes of interest difficult. Numerical modelling—meaning in this case the solving of differential equations in a 2-D or 3-D space by approximation with an algebraic system of equations—has been shown to be an effective bridge between scientific disciplines by allowing students to conduct ‘what-if’ scenarios and recognise connections between processes (Schneider, 1999); however, without connection to real-world systems, students may walk away from these exercises without an improved understanding of the magnitude and importance of controlling processes. For example, students of hydrogeology may be able to run through numerical models without having a sense of the physical scale of these systems, the rates of flow, or the size of storage reservoirs (e.g. Dickerson, Callahan, Van Sickle, & Hay, 2005). That said, models play an important role in determining how to use mathematical skills to synthesise multiple types of data, each type with its own scale of support, which is a first step in determining appropriate data collection procedures for quantifying processes in the field. Exploration of models encourages students to operate at higher cognitive levels involving application and analysis as opposed to simply gaining knowledge and understanding, which is a more typical objective in undergraduate courses (e.g. Perkins, 2007).

Here, we test the hypothesis that hydrogeology students will better estimate rates, mechanisms, and the magnitude of parameters controlling groundwater flow and contaminant transport by linking physical and numerical models. Additionally, by comparing a ‘true’ and numerical system, students will better understand the importance of boundary conditions on hydrogeologic systems and the mathematics that control physical processes. Developing numerical models allows students to think creatively and critically about real-world problems, which is a valuable skill that translates to other areas of life, regardless of future career choices (Halaby, 2001). We have developed a coupled physical and numerical modelling exercise around an issue of societal importance—contaminant transport—to provide undergraduate students with an opportunity to control and explore physical processes. A particular difficulty is getting students to understand solutions to partial differential equations.
(PDEs) in sciences that are dependent on these mathematics, such as hydrogeology, without having taken these prerequisite classes. By allowing them to explore how the behaviour of a domain is controlled by its boundary conditions and internal heterogeneity, they can build intuition about the solutions of PDEs they might not yet have been exposed to. The exercise is challenging for young undergraduate students, yet holds their attention while improving: (1) their estimation of groundwater velocities and (2) their understanding of boundaries in real ground water flow domains as well as their implementation as boundary conditions in numerical models. Learning objectives include determining transport velocities for a conservative tracer in heterogeneous settings; solving a PDE numerically and explaining its physical meaning; and discussing possible reasons for deviations between predicted and measured results from a numerical model by choosing the most likely reason and justifying the choice. While the example here is specific to a hydrogeology, this idea of coupling physical and numerical models in COMSOL could be extended to many other physical disciplines, and similar experiments could be conducted in other undergraduate classrooms.

Methods

The exercise described here involves numerical models using COMSOL Multiphysics and 2-D ‘ant farm’ physical models used for flow and transport. The physical modelling takes one full class period (on the order of an hour) and the numerical modelling, including introducing COMSOL, will take a full lab period (on the order of three hours). The study results presented here are limited in scope in that this exercise was conducted on a small sample size of students (eight) at one location. We note that all conclusions drawn about student learning are made solely within the context of this sample; however, the insights gained will aid in developing new practices for linking scientific problem-solving, physical and numerical modelling, and visualisation of physical processes. We assess learner reactions to the class activity through written, non-graded, short-answer, pre- and post-assignment tests. While this type of assessment is teacher-directed, we discussed both pre- and post-assessments with the students to reinforce the material and explain how we, as teachers, learn from their feedback.

Many hydrogeology classes use 2-D ‘ant farms’ to demonstrate flow and transport processes to students (e.g. Passey, Cerling, & Chan, 2006), and we also exploit their use in this exercise. Students use these tanks to explore how forcing functions change the internal dynamics of the system. In the exercise here, the students additionally create numerical models based on these physical models, giving them the opportunity to get involved in numerical modelling of systems that they already have had some exposure to and thus making the solutions of the PDEs within these numerical codes more meaningful. In this exercise, we combine experimentation in a 2-D physical model of a subsurface aquifer (Figure 1) with 2-D flow and transport models.

Undergraduate geoscience students complain that the service classes offered by computer science departments do not meet their needs or address the skills they need.
as scientists (Schneider, 1999), and many numerical codes are written such that students never have to think about the mathematics behind the numerical model. To overcome these hurdles, this exercise uses COMSOL Multiphysics, a versatile program that allows for numerical modelling in a more user-friendly environment than traditional languages such as Fortran or C. This software package has successfully been used to ‘bring partial differential equations to life’ for undergraduate students, who have modelled cooling of motorcycle engine blocks, for instance, after a brief introduction to the code (Bhatia, 2007). The downside to COMSOL for educational use is its cost; a class kit license with 30 seats costs approximately $3,000.

In this exercise, the Earth Sciences Module of COMSOL is used to numerically model fluid flow and solute transport. A review of COMSOL’s Earth Sciences Module for simulating groundwater flow can be found in Li, Ito, Wu, Lowry, and Loheide (2009). With COMSOL, the students can create and analyse numerical models without needing to be trained in computer science or computer coding; instead, they need to understand the fundamental controls on the physical processes in the subsurface: the initial conditions, the boundary conditions, and the mathematical representation of the physical processes of interest. When coupled with experimentation, students can use numerical modelling to actively predict real-world processes, and can also explore how simplifications of numerical systems lead to differences in the resultant behaviour from their experiments. Prior to using the

Figure 1. Steady-state flow conditions in the 2-D sand tank prior to dye injection. The underground storage tank (UST), lagoon, and lake features are labelled. Flow goes from left to right, and the approximate locations of the initial heads (and boundary conditions) are shown with the dotted line.
physical or numerical models, we reviewed the physical meaning of derivatives and covered basic hydrologic concepts as described below. Approximately four hours of lecture classes were provided before this exercise was started; this included time to derive and explain the groundwater flow equation (GWFE; described below) as well as introduce students to flownets, or 2-D solutions to the steady-state GWFE (e.g. Gates, Langford, Hodgson, & Driscoll, 1996), to help build intuition about groundwater flow and introduce the concept of boundary conditions. Students in this hydrogeology class came from a range of backgrounds: not all students were geoscience majors; all had taken Calculus I and some had taken Calculus II, but none had taken a differential equations class. Students worked in groups of two or three during both experimentation and modelling. Allowing the students to work in pairs or groups provided them with an opportunity to articulate their experiences and ideas and resolve differences between their conceptual understanding of processes and those of their peers.

Sand Tank Experiments

We use sand tanks similar to those found at Ward’s Natural Science (http://ward-sci.com/product.asp_Q_pc_E_IG0012168_A_Groundwater+Simulation+System) or sold by the University of Wisconsin-Stevens Point (http://www.uwsp.edu/stuorg/awra/h2omodel.html), which can be used to demonstrate hydraulic gradients or well interference, as well as processes like groundwater–surface water interaction and contaminant (food dye) transport. These physical models allow students to visualise subsurface processes—and then change the forcing functions that affect them—providing a hands-on way to help students intuit behaviour in field settings. While many different experiments can be run with these tanks, we focus on a simple example here, where the boundaries are kept at fixed heads such that flow goes from left to right (Figure 1). After reaching steady-state flow, the students introduce food dye into the leaking underground storage tank (UST) at the left end of the sand tank. The food dye moves with the natural gradient across the tank, eventually leaving from the downstream boundary. Because the UST is near the surface, most of the dye stays near the top of the system (Figure 2). Additions can be made to the experiment conducted here, such as ‘pumping’ one of the deep wells, using syringes to change the flow field while the dye moves to pull the plume downward. Sand tank experimentation generally takes one full class period.

2-D Derivation of the Groundwater Flow and Advective–Dispersive Equations

Although the students have not taken differential equations, we go through the derivation of the 2-D GWFE together, where we concentrate on the components of the GWFE: (1) the conservation of mass:

$$\Delta S = I - O$$  \hspace{1cm} (1)
Figure 2. Snapshots of solute transport from sand tank physical model
where $S$ is the storage, $I$ is the input, and $O$ is the output; and (2) Darcy’s Law:

$$q = -K \frac{\Delta h}{\Delta t}$$  \hspace{1cm} (2)$$

where $q$ is the specific discharge [$L/T$] (equal to the average groundwater velocity times the porosity), $h$ is the hydraulic head [$L$], $K$ is the hydraulic conductivity [$L/T$], and $l$ is the spatial dimension along which flow is occurring [$L$]. While a PDE might not have physical meaning to most undergraduate students, both of these equations can be parsed apart. Equation 1 is analogous to tracking one’s finances—where the ‘storage’ in one’s bank account increases and decreases with deposits and withdrawals. Equation 2 indicates that flow is driven by a change in head, controlled by hydraulic conductivity, a parameter that describes water’s ease-of-flow. As a class, we walk through the integration of Equations 1 and 2 to develop the GWFE in 2-D (vertical cross section):

$$S_s \frac{\partial h}{\partial t} = \frac{\partial}{\partial x} \left( K \frac{\partial h}{\partial x} \right) + \frac{\partial}{\partial y} \left( K \frac{\partial h}{\partial y} \right)$$  \hspace{1cm} (3)$$

where $S_s$ is the specific storage [1/$L$] and $t$ is time [$T$]. Because this is often the first contact with a PDE for many students, we concentrate on translating this equation to them and making sure they see the connection between Equation 3 and Equations 1 and 2: the left-hand side is simply their change in storage, and the right-hand side is the spatial variation in the Darcy flow. Given Equation 3, we talk about how to tell if a PDE is steady-state or transient (based on whether the time component in the equation exists). For example, the steady-state 2-D GWFE is given by:

$$0 = \frac{\partial}{\partial x} \left( K \frac{\partial h}{\partial x} \right) + \frac{\partial}{\partial y} \left( K \frac{\partial h}{\partial y} \right)$$  \hspace{1cm} (4)$$

which no longer shows a time dependence. We also discuss how to change Equation 3 for a homogeneous $K$. If $K$ is constant in space, then it can be pulled out of the spatial derivative and Equation 3 would be written as:

$$S_s \frac{\partial h}{\partial t} = K \left( \frac{\partial^2 h}{\partial x^2} + \frac{\partial^2 h}{\partial y^2} \right)$$  \hspace{1cm} (5)$$

From here, we discuss what happens to $K$ if the equation was steady-state and homogeneous—$K$ falls out of the equation—and why that means that we never need to know $K$ to draw head lines on flownets, since flownets are a steady-state solution to the GWFE. Having spent time with this equation, we go through a parallel derivation of the advective–dispersive equation, noting that chemical fluxes are driven by both advection and diffusion processes. Consequently, when applying conservation of mass, we must track transport via both processes, neglecting cross terms, leading to:
where \( C \) is the concentration \([M/L^3]\) and \( D \) is the dispersion coefficient \([M/T^2]\).

Derivation of these equations generally takes one class period.

The solution to these equations is dependent on the boundary conditions. This idea is not new to the students from their experiences with flownets. From flownets, students recognise that impermeable materials should be thought of as a no-flow boundary, and that bodies of fixed head, like perhaps some rivers, can also be used to define boundary conditions. These boundary conditions control the head distribution within the bounded domain of their flownets in the same way that the boundary conditions control the heads within the sand tank and will control the head distribution within the bounded domain of their numerical models.

After completion of these tutorial classes, students are asked to complete a written pre-exercise assessment that asks them the following questions: (1) How does water move in the subsurface? What controls how quickly it moves? (2) What would you estimate to be the velocity of groundwater flow in a subsurface sand aquifer? How did you arrive at this number? (3) How are groundwater flow and the transport of contaminants related? Can contaminants travel more slowly or more quickly than groundwater? If so, how?

A Brief Introduction to COMSOL

Before introducing the sand tank numerical model in COMSOL, the students must have some familiarity with the code. To learn the basics of COMSOL, students in groups of two build a simple \(20 \times 20 \text{ m}\) 2-D box using the Darcy’s Law application (see Appendix). The Darcy’s Law application solves for pressure head given in Equation 3 in 3-D. Using a steady-state (or in COMSOL’s language, ‘stationary’) solver, they calculate hydraulic heads. COMSOL calls any piece of the original domain with a different property (in flow or transport) its own ‘subdomain’. For instance, a block of low permeability material could be defined as a separate subdomain, as would the introduction of an ellipse to indicate a concentration plume at some time \(t\). After drawing their domain, students set the subdomain settings (homogeneous hydraulic conductivity and initial heads), and boundary conditions (two no flow boundaries perpendicular to two fixed head boundaries that impart a hydraulic gradient across the field). They then solve for heads, and build in complexity by adding a single point well, and re-solving.

Having completed a simple steady-state flow model, the students then couple their flow model to the solute transport application using the saturated porous media selection and transient analysis. One of the benefits of using COMSOL is that the students must couple the flow and transport models together themselves. The flow model will solve for the groundwater velocities in 2-D (called \(u_{esdl}\) and \(v_{esdl}\) in COMSOL, where ‘esdl’ stands for Earth Sciences Darcy’s Law); these must be
inserted into the subdomain settings of the transport model explicitly where it asks for velocity data. The students consequently recognise that the parameter that connects flow and transport is velocity. They introduce a new subdomain that represents a contamination plume, and monitor its transport through time. To do so, they must define the boundary conditions, and can explore how changing these conditions affects the resultant head or concentration field. The predicted flow velocities from the flow model are passed to the Solute Transport application, which solves for concentration given Equation 6. The students then animate the transport of the solute using results from their numerical model.

**Application of COMSOL to the Sand Tank Models**

After this introduction to building the simple numerical models above, the students are given a numerical model based on the sand tanks that already includes the key features (Table 1; Figure 3). This numerical model has a heterogeneous hydraulic conductivity field to match the sand tanks. The open water bodies are simply parameterised as high permeability regions. The UST, which is the source of contamination, is parameterised as a separate subdomain. While this model is more complex than the simple homogeneous numerical model they had created previously, the students are familiar with the program’s menus and move between applications and menus easily having already had an introduction to COMSOL. The students do not edit this numerical model, as they did their introductory ones, but rather explore the parameters within the model and run it.

Given this sand tank-based model, the students are asked to go within the Darcy’s Law application and determine what the simplifications of the numerical model are.

![Figure 3. COMSOL numerical model based on sand tank. Materials correspond to hydraulic conductivities given in Table 1](image)

---

**Figure 3.** COMSOL numerical model based on sand tank. Materials correspond to hydraulic conductivities given in Table 1
with respect to the physical model, locate the important parameters within each subdomain ($K$, initial heads, etc.), and determine whether the assigned values make physical sense. Similarly, they explore the boundary conditions (a head boundary at either side, no flow on the bottom, a water table boundary on the top, and continuity boundaries internally), and are asked to determine what the expected behaviour would be given these boundaries, based on intuition and the previous work. While we did not delve into details of how the upper boundary was constructed with the students, the water table is represented as a spatially variable head distribution where the head is specified as the $y$-coordinate in COMSOL, based on the classic work of Tóth (1963). This allows for the exchange of water across the water table boundary. The upper boundary is specified as a no-flow boundary across the open water bodies.

After exploring the Darcy’s Law application, the students run the forward model for steady-state heads, and describe the pattern of heads, comparing the results to their expected behaviour (Figure 4).

After running the Darcy’s Law application, the students store the solution, and select the Solute Transport application. As with the Darcy’s Law application, the students are asked to explore the subdomain parameters and boundary conditions and explain their physical significance. The UST is different than the other subdomains in that it has a ‘solute source’ term (COMSOL calls this term $S_0$) assigned to it, in units of $M/L^3T$, indicative of a concentration per time. Again, the students are asked to make predictions of the behaviour. The numerical model is then solved with a transient solver to simulate transport through the aquifer (Figure 5). A common problem is to forget to use the output from the Darcy’s Law application (using ‘Store Solution’, e.g.); in this case, the students find that their solute plume only diffuses as the velocities are not passed forward to the new application model, which serves as a useful lesson.

As mentioned with respect to the physical model above, this exercise can be expanded by introducing pumping wells, for example, and allowing students to conduct ‘what if’ scenarios. If the instructor chooses, the numerical and physical

<table>
<thead>
<tr>
<th>Physical parameters used in the numerical models of flow and transport</th>
</tr>
</thead>
<tbody>
<tr>
<td>Hydraulic conductivities (m/s)</td>
</tr>
<tr>
<td>$10^{-2}$ (gravel), $10^{-4}$ (background sand),</td>
</tr>
<tr>
<td>$10^{-5}$ (fine sand), $10^{-6}$ (poorly sorted sand),</td>
</tr>
<tr>
<td>$10^{-9}$ (clay), $10^{6}$ (water bodies)</td>
</tr>
<tr>
<td>Left boundary condition</td>
</tr>
<tr>
<td>0.35 m (head), 0.01 kg/m$^3$ (concentration)</td>
</tr>
<tr>
<td>Right boundary condition</td>
</tr>
<tr>
<td>0.2 m (head), advective flux (concentration)</td>
</tr>
<tr>
<td>Initial conditions</td>
</tr>
<tr>
<td>0.3 m (head), 0.01 kg/m$^3$ (concentration)</td>
</tr>
<tr>
<td>Porosity</td>
</tr>
<tr>
<td>0.25</td>
</tr>
<tr>
<td>Dispersivity, primary direction</td>
</tr>
<tr>
<td>0.001 m</td>
</tr>
<tr>
<td>Dispersivity, secondary direction</td>
</tr>
<tr>
<td>0.0001 m</td>
</tr>
<tr>
<td>Tortuosity</td>
</tr>
<tr>
<td>0.5</td>
</tr>
<tr>
<td>Coefficient of molecular diffusion</td>
</tr>
<tr>
<td>$1 \times 10^{-5}$ m$^2$/s</td>
</tr>
<tr>
<td>Contaminant source in UST</td>
</tr>
<tr>
<td>30 kg/m$^3$s</td>
</tr>
</tbody>
</table>
modelling can be considered iteratively, where the students test scenarios in COMSOL, explore whether the behaviour in the physical model performs similarly, and return to COMSOL to update their understanding of the system. We note that COMSOL pumping wells in 2-D simulations and in 2-D tanks will produce different results from an actual well which induces radial flow, but that for qualitative comparison, this is not a major concern.

**Discussion**

A number of differences exist between the physical and the numerical models. For instance, when prompted to explore differences between the two systems, the students note that: (1) the numerical model boundaries are assumed to be steady state (which is not exactly the case in the physical models, where the downstream boundary, in particular, oscillates slightly); (2) the water bodies are merely assumed to be the zones of very high hydraulic conductivity (1e6 m/s); and (3) the water bodies in the numerical model are connected to the aquifer at all locations rather than just at a couple of holes in the plastic in the physical model. The students realise that each type of model has its own strength: the physical models allow students a hands-on experience that is ‘real world’, while the numerical models allow students to easily alter parameters and see how that affects the behaviour of a system. Additionally, numerical models can be used within a similar course setting for hypothesis testing about flow and transport in a more flexible way that may not be available with a physical model.
Figure 5. Snapshots of contaminant concentration from the COMSOL solute transport model. Steady-state hydraulic head contours are superimposed on the solution.
The feedback from the students indicates that it was useful to them to see a numerical model that was tied to a process that they had witnessed. The representative feedback from the students’ post-course survey included: ‘It was helpful [to run a numerical model based on the sand tanks] because … working a model was more useful when you could relate it back’, ‘it brought everything together’, ‘[the numerical model] helps us to better understand the parameters and their significance associated with the sand tank experiments’, and ‘it was helpful to see where theoretical errors in a model or even a sand tank can occur and how important they are to results and observations’. Post-exercise testing showed that they could better approximate transport velocities and intuit how different forcing functions would change flow and transport. For instance, before this activity, students in this class estimated groundwater velocities in a simple sand aquifer to be, on average, around 500 cm/s, which is likely orders of magnitude too fast in most systems. Post-exercise, the average of their estimates was still high—on the order of 2 cm/s—but these were biased by a few larger guesses. Figure 6 is a plot of student-estimated groundwater velocities for a sand-and-gravel aquifer after classroom lessons on Darcy’s Law and the GWFE compared with those after the exercise described here. After working with the physical model, many of the students estimated velocities by approximating the values of the parameters within Darcy’s Law and then using that equation; despite familiarity with the equation prior to the exercise, no students used the equation to estimate groundwater velocities and the numbers written seemed more to be guesses (a few had incorrect units). Pre-exercise, many students also thought contaminants could move faster than groundwater velocities (true only if diffusion is the controlling process); for example, one student commented that ‘A contaminant can travel more quickly than groundwater. It all depends on the density of the

Figure 6. Histogram of estimated groundwater velocities pre-exercise (grey with white stripes) and post-exercise (white with black stripes). Note that the number of responses is not the same pre- and post-exercise because some pre-exercise estimates were not in units of velocity.
contaminant’. Post-exercise, this same student commented that ‘contaminants would travel more slowly’. Others noted that ‘Contaminants can travel more slowly than the speed of groundwater because of dispersion. I don’t believe it can travel faster than groundwater because groundwater is the primary driving force of its transportation’. Students also recognised that velocities were the key term connecting flow and transport, as noted in numerous comments such as this one: ‘Velocity plays a key role because it tells us something about the magnitude of the flow and the rate at which a substance is transported in the water’. In these post-course surveys, students stated that the development of numerical models gave them confidence to predict flow and transport for real scenarios.

The results of this study show that while many of the students had misconceptions about flow and transport rates and mechanisms in the subsurface, the linking of physical and numerical modelling allowed them to better quantify behaviour. Importantly, they are also intuited the solutions to PDEs. By tying a basic numerical model to a physical model, students start understanding the language of PDEs without having had a mathematics class in them; this serves to strengthen their implicit understanding of applied mathematics.

Demonstrations have been shown to be effective for illustrating processes, but without active participation, students may end up passively responding (National Research Council, 1997). We aimed to produce an active-learning exercise that would enhance student learning of subsurface processes, including the strengthening of quantitative skills and intuition for mathematical equations. While the results here were tested on a small number of students, and are specific to hydrogeologic models, the concept of linking physical and numerical models should hold for other physical geosciences such as geomorphology, volcanology, or seismology where physical models could be easily constructed and tied to mathematics using computer models, including COMSOL.

Conclusions

One common obstacle with teaching groundwater modelling is that because the students cannot ‘see’ what happens in the subsurface, the simulation of times of transport or the effect of low-permeability materials does not have a physical meaning. Using 2-D sand tanks and COMSOL Multiphysics, students explored flow and transport behaviour in a heterogeneous subsurface aquifer system. Through coupled physical and numerical modelling, students better predict behaviour, test for outcomes, and explore how to best produce those results numerically. Linking physical and numerical models in a controlled setting improved students’ intuition of physical processes and allowed them to better understand the power (and limitations) of numerical modelling. This exercise also introduces undergraduate students to PDEs in an applied setting, and helps them to recognise the importance of boundary conditions. We show that the integration of numerical and physical groundwater models can improve students’ estimation of the rates and controls of groundwater flow and transport, and provide a forum for confronting and breaking
down misconceptions about subsurface processes. Additionally, we found that collaborative learning was an excellent tool to bring undergraduates comfortably into highly quantitative sciences.

Acknowledgements

The authors appreciate the efforts of Brad Kuntz, Rachel Lauer, and Daniel Wheaton in helping to develop the exercise shown here, and the students of a summer hydrogeophysics field course for testing these exercises with such alacrity. The work was supported in part by NSF CAREER grant EAR-0747629.

References

Appendix

This appendix includes an abbreviated version of the material we use with the students to introduce COMSOL. Here, a simple example of flow and transport is outlined; this could be greatly expanded to highlight other options. More screen shots could also be added to the key ones shown here.

To start, click on the COMSOL Multiphysics shortcut under Start → Programs. The Model Navigator will open:

![Model Navigator](image1)

**Modelling Flow**

From here, choose the New tab, and make sure the space dimensions are set to 2-D. We will be creating map view models today. You’ll now select your Application Mode. Under the Earth Science Module, choose Fluid Flow → Darcy’s Law → Hydraulic Head → Steady State analysis.

![Model Navigator](image2)
Hit OK. SI units (kg, m, s) are the default values. From here, the default window will open, showing the Drawing Environment. Use the Draw → Specify Objects → Square menu. Set the Square to have a side length of 20, and place the corner of it at (0, 0). This will be your flow and transport domain. Fit your new rectangle to screen by selecting the Zoom tool (two red arrows intersecting perpendicularly).

**Defining parameters, initial conditions.** We now need to set the properties within this domain, specifically the hydraulic conductivity and initial heads. To do this, go to the Physics → Subdomain Settings menu, or click the button highlighted in red below. You should see the GWFE written out at the top of the menu. This is the equation we’ll solve.

Select the only subdomain we have (#1), and in the main Coefficients Menu, assign a saturated hydraulic conductivity of 1e-4 m/s, which is a reasonably high hydraulic conductivity, like what you would find in a clean sand.

Click the Init tab and set your initial heads. Let’s assume we have an initial head of 10 m. This parameter won’t matter much, although we must set it. The sensitivity of our results to initial conditions is not high in a well-behaved system like the one we have here.

**Defining boundary conditions.** Next, we need to assign the behaviour at our boundaries. To do so, click on Physics → Boundary Settings. Click on the four edges of your square to figure out which boundary is defined as which number.

We’ll set up a system where flow goes from left to right, although we could do whatever we’d like. To do this, we’ll set the top and bottom boundary to the default values (No Flux) such that no flow goes through them and the left and right boundaries to fixed head. Let’s set a natural gradient of 0.01. Over a 20 m domain, this would be a head change of 0.2 m. To do this, click on the number associated with the left boundary and assign a hydraulic head of 10.2 m. Click the number associated with the right boundary and assign it a hydraulic head of 10.0 m. This will establish your gradient of 0.01. Does that make sense?

Once you’ve set the boundary conditions, you’ll note that COMSOL colours the no-flow boundaries black, and the two head boundaries are in colour.

**Defining the mesh.** We are almost ready to simulate: we have our domain, our boundary conditions, our initial conditions, and our differential equation of interest. We’ve assigned the parameters we need. From here, we just need to mesh. To do so, go to Mesh → Generate Mesh.

Behind the scenes, what’s happened here is that COMSOL has discretised our differential equation so that we can solve it numerically rather than graphically (like we did with flownets). COMSOL is going to solve for the values of head at every node.
If you choose to, you can refine the mesh by using Mesh → Refine Mesh. This makes your solution more accurate but your model will run a bit slower.

**Solving model for hydraulic heads.** From here, we can click the equal sign (or use the Solve menu) to find hydraulic heads at each point. Before we do this, let’s look at the inner workings of the COMSOL Solve Menu as we’ll be using it a lot.

First, go to Solve → Solver Parameters. Note that the solver is set to Stationary—this means we are looking for the steady-state solution.

Click OK. Go to Solve → Solver Manager. We won’t change the Initial Value Setting today, but we will change the Values menu at the bottom. For now, we want it to Use Setting from Initial Value, meaning we’re solving from the initial conditions we specified earlier.

Under the Solve For tab, you’ll see our only option at the moment, and that is to solve the Darcy’s Law module for \( p \) (pressure). To solve from this menu you can click Solve, or hit OK and the equal sign button.

**Plotting hydraulic heads.** The hydraulic head field plots instantly after running the simulation.
We see that we’ve produced a map of hydraulic head that has high head (10.2 m, to be precise) at the left-hand boundary, grading to lower head (10.0 m) on the right-hand side. This is no surprise, and we could have done this with a flownet. But we’ll build from here by adding transport. Transport is dependent on the velocities from the flow model, so let’s save this Darcy’s Law solution so that the heads and velocities can be used in the transport application. Go into Solve → Solver Manager and click Store Solution.

We have a lot of other plot options. You can find them in Post-Processing → Plot Parameters.

**Modelling Transport**

To add transport, we need to choose the advective–dispersive equation to model. To do this, we need to head back out to the Model Navigator. To do this, click Multiphysics → Model Navigator, and select Saturated Porous Media → Transient Analysis option under the solute transport module. When you click Add in the right-hand corner, you should now see both the Darcy’s Law and Solute Transport applications in the window on the right-hand side. Click OK.
Defining parameters, initial conditions.  Like with the flow model, we now need to define the properties controlling transport. Think about the advective–dispersive equation: what parameters do we now need to add? Porosity and dispersivity are the big ones. We also need to pass the velocities from the flow model to the transport simulation.

Under the Multiphysics menu, make sure you are in the solute transport application. If so, go to Physics → Subdomain Settings to set the parameters of interest.

Click on the only subdomain (#1) and assign a porosity of 0.3. Under the Liquid tab, set the dispersivity in Direction 1 to 0.2 and in Direction 2 to 0.02. Under Init, set the background initial concentration to 1 kg/m$^3$.

How do we connect the flow and transport models? Through velocity, right? So we need to somehow tell the solute transport module what the groundwater velocity is in $x$ and $y$ (labeled $u$ and $v$). To do so, we go back into the Darcy’s Law application, and select Physics → Subdomain Settings → Equation System. Click the Variables tab.

Here, we see all the parameters that have been defined. We can scroll through to find the $x$- and $y$-velocities by their description. They’re called $u_{esdl}$ and $v_{esdl}$. From here, go to Multiphysics, select solute transport again, and go under Physics → Subdomain Settings to pass these velocities to the transport simulation. Insert $u_{esdl}$ (the latter part stands for Earth Science Darcy’s Law) and $v_{esdl}$ into the Flow and Media Settings.
Click OK. The two models are now connected.

**Defining boundary conditions.** Like with the flow model, we need to define the boundary conditions for the advective–dispersive equation. Since we are coupling the two model systems, we will keep the boundaries similar in nature. The top and bottom boundaries will be no flux (since they are no flow). We need to fix the left-hand boundary such that it maintains our initial concentration, so we’ll see it as a fixed concentration boundary with a values of 1 kg/m$^3$.

The right-hand boundary we’ll set to an ‘Advective Flux’ condition. This allows the solute that arrives at the right-hand boundary to escape via advection.

**Defining the source location.** Let’s pretend we have a spill—a plume at the left-hand side of our domain. Let’s define the plume as an ellipse that is 2 m in length and 1 m in height. To define it, go to Draw → Specify Objects → Ellipse. Define the long axis as 2 and the short axis as 1 as shown in the menu below. You can centre the ellipse anywhere you’d like. I put it at (2, 10). If you’d like it elsewhere, that’s fine, just keep it on the left-hand side so it will not exit the domain too quickly.
You now need to define the concentration within the ‘spill’. To do so, go to Physics → Subdomain Settings. Note we now have two subdomains, as we’ve introduced the plume. Check that the subdomain Settings in #2 are the same as #1 (wouldn’t you expect the same porosity, etc.?). Then select the second subdomain (our ellipse), and under the Init menu, define the initial concentration within that domain as 10 kg/m$^3$. Click Apply.

**Solving for concentration.** We now have two simulations we need to run: (1) flow (to get velocities), which we’ll pass to the (2) transport model. Because our flow model is steady-state (meaning there are no changes with time) and our transport model is transient (as we’re tracking a tracer with time) we will need to solve these slightly differently.

To set these solver parameters, we’ll go to Solve → Solver Manager. We’ll then click the ‘Stored solution’ radio button to let COMSOL know that we’ll be running our transport model based on the previously stored flow model. We’ll then click the ‘Solve For’ tab to choose the solute transport application only.
From here, go into Solve → Solver Parameters to set the parameters for the transient transport model. Choose Transient analysis, the Time dependent solver, and then decide on the output times (in seconds) that you would like to see. We’ll run this test for 100 days, outputting results every day. In the Times window, you need to type the start time, a colon, the time step, a colon, and then the final time. Rather than use 86,400 seconds to indicate a day, let’s just use 1e5 to approximate the right number of seconds. So for approximately daily output for 100e5 seconds (116 days), type 0:1e5:100e5.
Hit OK, then Solve.

**Plotting concentration.** From within the Post-Processing → Plot Parameters menu, select concentration data to plot from the drop down menu under the solute transport application choices.

This will only plot the last time step. It may look like your concentration plume is still there, but take a look at the colourbar—most of the concentration has already been swept out of the field.

To explore the concentration fields at each day, go to the General tab and select whichever date you’d like, and click Apply. You should see the initial ellipse advect and disperse across the field as you move to later and later dates. You can turn on velocity arrows if you’d like as well. An example image from 10e5 seconds is shown below.